Mikrotik – UPnP

Włączenie UPnP na Mikrotiku
Wybieramy IP>>UPnP (zaznaczamy Enabled)

Wybieramy Interfaces

jako internal Interfejs z bridgem (lub inny interface, na którym ma być wybieramy UPnP)

jako external Interfejs, który jest WAN-em

Na koniec Apply

w konsoli:
/ip upnp set enabled=yes
/ip upnp interfaces
add interface=ether1-WAN type=external
add interface=bridge1 type=internal

Router Debian cz. 2

 

Instalacja i konfiguracja serwera DHCP

Zainstalowanie i skonfigurowanie serwera DHCP na interfejsie eth1 (eth0 – jest zawsze interfejsem WAN)
instalacja:
apt-get update
apt-get install isc-dhcp-server

edytujemy:
/etc/default/isc-dhcp-server
Dodajemy interfejs na którym ma działać server DHCP (jeśli mamy kilka interfejsów na których ma działać dhcp to dopisujemy po spacji np. INTERFACES=”eth1 eth2 eth3″ Odpowiednia podsieć zostanie przyporządkowana po adresie ip interfejsu.
INTERFACES=”eth1″

Continue reading

Router Debian cz. 1

Ustawienie w Biosie „POWER ON” po dostaniu napięcia z gniazdka.
Zainstalować system DEBIAN

zmiana w pliku z repozytorium sorces.list
nano /etc/apt/sources.list
zakomentować:
#deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch....
Zmiana portu w ssh edytyjemy w pliku:
nano /etc/ssh/sshd_config
zmieniamy
Port 557
Zezwolenie na logowanie roota, dopisujemy po:
#PermitRootLogin without-password
Dopisać to:
PermitRootLogin yes
zapisać i zrestarować serwis
service ssh restart

Continue reading

Co 2 minuty restart MAC OSX

Dziś co 2 minuty restartował mi się OSX. Przyczyną był uszkodzony TimeMachine. Naprawa to skasowanie Timemachine i zrobienie nowego.

 panic(cpu 3 caller 0xffffff7faffe985e): “hfs_UNswap_BTNode: invalid backward link

https://forums.developer.apple.com/thread/89865

 

Exchange 2010 zmiana InternalURL

Wyświetlenie obecnych url:

[PS] C:\Windows\system32>Get-WebServicesVirtualDirectory |fl identity,internalurl,externalurl

Identity : SERVER\EWS (Default Web Site)
InternalUrl : https://server.domena.local/EWS/Exchange.asmx
ExternalUrl : https://mail.domena.com/ews/exchange.asmx

Zmiana:

[PS] C:\Windows\system32>Set-WebServicesVirtualDirectory -Identity "SERVER\EWS (Default Web Site)" -InternalUrl https://mail.domena.com/EWS/Exchange.asmx BasicAuthentication:$true

ponowne sprawdzenie:

[PS] C:\Windows\system32>Get-WebServicesVirtualDirectory |fl identity,internalurl,externalurl

Identity : SERVER\EWS (Default Web Site)
InternalUrl : https://mail.domena.com/EWS/Exchange.asmx
ExternalUrl : https://mail.domena.com/ews/exchange.asmx

Sprawdzenie autodiscovera:

[PS] C:\Windows\system32>Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri

Identity : SERVER
AutoDiscoverServiceInternalUri : https://server.domena.local/Autodiscover/Autodiscover.xml

ustawienie nowego:

[PS] C:\Windows\system32>Set-ClientAccessServer -Identity SERVER -AutoDiscoverServiceInternalUri https://mail.domena.com/Autodiscover/Autodiscover.xml

Sprawdzenie:

[PS] C:\Windows\system32>Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri

Identity : SERVER
AutoDiscoverServiceInternalUri : https://mail.domena.com/Autodiscover/Autodiscover.xml

Restart IIS

[PS] C:\Windows\system32>iisreset /restart

Attempting stop...
Internet services successfully stopped
Attempting start...
Internet services successfully restarted

AFP Ubuntu 16.04

Zamontowanie zasobu po sambie

mkdir /mnt/timemachine

mount -t cifs //nazwa_servera_windows/timemachine$ /mnt/timemachine --verbose -o username=user_name,pass=haslo,dir_mode=0777,file_mode=0777

zainstalowanie

apt-get install netatalk

dopisanie w pliku: /etc/default/netatalk

ATALKD_RUN=no
PAPD_RUN=no
CNID_METAD_RUN=yes
AFPD_RUN=yes
TIMELORD_RUN=no
A2BOOT_RUN=no

edycja:  /etc/netatalk/AppleVolumes.default

/mnt/timemachine         "TimeMachine na backup" allow:user1,user2  options:tm

restart serwisów:

/etc/init.d/netatalk restart

źródło:https://mycyberuniverse.com/linux/afp-and-bonjour-under-linux.html

 

DNS – jeden wpis pomimo dwóch NIC

Problem:

Server AD, 2 karty sieciowe w różnych podsieciach LAN, iSCSI. Server DNS zwracał ip ze złej podsieci. Np. Będąc w podsieci LAN 192.168.0.0/24 zwracał ip servera z podsieci iSCSI 172.2.2.0/25.

Rozwiązanie:

To avoid this problem perform the following 3 steps (It is important that you follow all the steps to avoid the issue). 
1. Under Network Connections Properties: 
On the Unwanted NIC TCP/IP Properties -> Advanced -> DNS – > Uncheck “Register this connections Address in DNS” 

2. Open the DNS server console:  highlight the server on the left pane Action-> Properties and on the “Interfaces” tab select “listen on only the following IP addresses”. Remove unwanted IP address from the list

3. On the Zone properties, select Name server tab. Along with FQDN of the DC, you will see the IP address associated with the DC. Remove unwanted IP address if it is listed.

 After performing this delete the existing unwanted Host A record of the DC.

Źródło: https://support.microsoft.com/uz-latn-uz/help/2023004/steps-to-avoid-registering-unwanted-nic-s-in-dns-on-a-mulithomed-domai