Automatyczne mapowanie dysku vhd podczas startu systemu Windows

Fajna sprawa “dyski” vhd można w łatwy sposób mapować nawet po ścieżce UNC z innego servera zawartość pliku mapowanie_vhd.txt

select vdisk file=”\\net_share\backup.vhd”
attach vdisk
exit

łatwo z poziomu powershella dodać taska mapującego dysk po starcie systemu z opóźnieniem 4 minuty:

schtasks /create /tn "mapowanie_vhd" /tr "diskpart.exe /s 'c:\skrypty\mapowanie_vhd.txt'" /sc ONSTART /ru administrator /rp hasło_administratora /DELAY 0004:00

Eksportowanie virtualek

# skasowanie plików i folderow starszych niz 30 dni
$date = (Get-Date).ToString('dd_MM_yyyy')
# tworzenie folderu - nie wywala bledu nawet jesli istnieje
New-Item -ItemType Directory -Force -Path "E:\BACKUP_VIRTUALKI\"
Get-ChildItem –Path "E:\BACKUP_VIRTUALKI" -Recurse | Where-Object {($_.LastWriteTime -lt (Get-Date).AddDays(-30))} | Remove-Item -Recurse -Force
New-Item -ItemType Directory -Path "E:\BACKUP_VIRTUALKI\$date"
Export-VM -NAME "SERVER01" -Path "E:\BACKUP_VIRTUALKI\$date\"
Export-VM -NAME "SERVER02" -Path "E:\BACKUP_VIRTUALKI\$date\"
Export-VM -NAME "SERVER03" -Path "E:\BACKUP_VIRTUALKI\$date\"
Export-VM -NAME "SERVER04" -Path "E:\BACKUP_VIRTUALKI\$date\"

Mikrotik i BufferBloat

BufferBloat na Mikrotiku

/ip firewall filter
set [find where action=fasttrack-connection] disabled=yes
/queue type
add kind=sfq name=sfq-default sfq-perturb=10
/queue simple
add max-limit=10M/100M name=sfq-default queue=sfq-default/sfq-default target=192.168.88.0/24

Sprawdzenie czy jest poprawa:

http://www.dslreports.com/speedtest

źródło:

https://www.reddit.com/r/mikrotik/comments/7pl4f6/managing_bufferbloat_with_mikrotik/

Automatyczna aktualizacja ip w freedns.42.pl

Wysłanie powiadomienia na maila

    1. instalacja mailx
      sudo apt-get install heirloom-mailx
    2. zapisanie plikunano ~/.mailrco zawartości:
      account gmail {
          set smtp-use-starttls
          set ssl-verify=ignore
          set smtp-auth=login
          set smtp=smtp://smtp.gmail.com:587
          set from="noreply@yourdomain.com(Your Real Name)"
          set smtp-auth-user=noreply@yourdomain.com
          set smtp-auth-password=your_less_secure_apps_password
          set ssl-verify=ignore
      }